Download Pickit robot programs

Pickit provides robot programs for all supported robot brands. For now, Pickit supports:

ABB

Pickit is compatible with controllers as of version IRC5 with RobotWare 5 or 6 and furthermore. To communicate with Pickit, the modules 616 PC interface and 623-1 Multitasking should be installed.

Fanuc

Pickit is compatible with controllers as of version R-J30iA (i.e. R-J30iA - V7.X , R-J30iB - V8.X and R-J30iB plus - V9.X) and the software module User Socket Msg for socket communication is required (the product number for this module is A05B-2600-R648).

Hanwha

Pickit is compatible with controllers as of version 2.001. Rodi 2.001 for socket communication is required.

KUKA

Pickit is compatible with KR C2, KR C4 and Sunrise controllers.

For KR C4 controllers, the KUKA Connect KRC software module is required for socket communication. The product number for this module is 91B300-020 and can be purchased through Pickit. Contact sales@pickit3d.com for more information and pricing.

Omron TM

The Pickit TMflow components are available for TMflow version 1.72 and higher.

ROS

To communicate with Pickit using the ROS interface, you need to have the im_pickit_msgs package in your workspace.

Stäubli

For Stäubli software version 7 and higher.

Universal Robots

  Supported versions
Download link Pickit Polyscope (e-series) Polyscope (CB-series)
Pickit URCap 2.0.0 (recommended) ≥2.2.0 5.4 - 5.5* 3.10 - 3.11*
Pickit URCap 1.4.0 ≥1.8.2 5.0 - 5.4* 3.4 - 3.10*
URScript legacy interface ≥1.4 5.0 - 5.4* 3.0 - 3.10*

* The most recent supported Polyscope version represents what has been officially tested by Pickit. More recent Polyscope versions typically work out-of-the-box.

Yaskawa

Pickit is compatible with controllers DX200, YRC1000 and YRC1000 micro.